CorradoDelBuono.it

La logica di Microsoft Excel: la funzione SE e gli operatori logici.

Corrado Del Buono

Le funzioni logiche di Microsoft Excel sono indispensabili quando si inseriscono nel foglio di calcolo formule che dovranno essere calcolate soltanto al verificarsi di certi eventi, o che devono prendere in considerazione solo valori che soddisfano determinati presupposti, ma sono altrettanto utili per creare dei modelli “interattivi”, ovvero modelli che modificano certi dati (valori o etichette) al verificarsi o meno di certe condizioni. Analizziamo, con opportuni esempi, come si utilizza la funzione SE nella sua veste semplice o nidificata o con l'aggiunta degli operatori logici forniti dall'applicativo.

Pagina 3

Le funzioni E e O

La funzione E e la funzione O, anch'esse appartenenti alla categoria LOGICHE, consentono di testare simultaneamente più condizioni, e quindi forniscono alla funzione SE un valido aiuto nell'esprimere tutte le sue potenzialità.

La funzione E considera verificato un evento se TUTTE le condizioni sono soddisfatte, mentre la funzione O considera verificato un evento se ALMENO UNA condizione è soddisfatta; le sintassi sono:

=E(condizione1;condizione2;…)

=O(condizione1;condizione2;…)

Vediamo qualche semplice esempio per chiarire l'utilizzo di queste funzioni abbinate alla funzione SE.

Esempio 4

Nella cella A5 vogliamo inserire la scritta “test superato” se almeno uno dei risultati delle celle A3 e A4 è maggiore o uguale a 6, o nel caso contrario, la stringa “rifare test”.

Nella cella A5 potremmo utilizzare la seguente funzione:

=SE(O(A3>=6;A4>=6);”test superato”;”rifare test”)

Esempio 5

Se il valore della cella F1 è compreso tra 1 e 10, nella cella F3 inseriamo la moltiplicazione tra questo valore e quello contenuto nella cella F2, altrimenti inseriamo il valore 0.

Nella cella F3 potremmo utilizzare la seguente funzione:

=SE(E(F1>1;F1<10);F1*F2;0)

Esempio 6

Nella cella B4 vogliamo inserire l'etichetta “calcolo esatto” se i valori delle celle B1 B2 e B3 sono uguali, altrimenti l'etichetta “calcolo errato”.

Nella cella B4 potremmo utilizzare la seguente funzione:

=SE(E(B1=B2;B2=B3);”calcolo esatto”;”calcolo errato”)

Esempio 7

Nella cella B10 vogliamo inserire la moltiplicazione tra le celle B1 e la cella B2 se la cella A1 o la cella A2 contengono dei valori compresi tra 50 e 100, altrimenti solo il valore della cella B1.

Nella cella B10 potremmo utilizzare la seguente funzione:

=SE(O(E(A1>50;A1<100);E(A2>50;A2<100));B1*B2);B1)

Webmaster & designer: Corrado Del Buono - CONTATTI - © Tutti i diritti riservati.

PRIVACY: Questo sito utilizza cookie di terze parti (Google AdSense, Google+ e Google Analytics) per migliorare servizi ed esperienza dei lettori. Maggiori dettagli